本博客包含多个文档和书籍的翻译,但有能力者推荐阅读英文原版

CentOS 6.x 上如何升级php

PHP Alan 4年前 (2016-02-02) 1102次浏览 0个评论

我们都知道CentOS 6.x上的PHP版本为5.3.3,那么如果想要升级到更高的版本要怎么办呢?

这里使用Magento官方文档中提到的rpm包来进行相关安装

# 不加第一个有可能会报Requires: libmcrypt.so.4的错误
rpm -Uvh https://dl.fedoraproject.org/pub/epel/epel-release-latest-6.noarch.rpm
rpm -Uvh https://mirror.webtatic.com/yum/el6/latest.rpm
yum install -y php56w php56w-opcache php56w-xml php56w-mcrypt php56w-gd php56w-devel php56w-mysql php56w-intl php56w-mbstring php56w-bcmath

但是如果之前已经安装过php的朋友可能会发现无法进行安装,此时请先删除php-common即执行

yum remove php-common -y 

再进行安装可发现会正常进行新版本的升级,我这里演示的是5.6.x的版本,您也可以选择PHP 7.0(php70w...),如果您选择的是其它的rpm包,可通过如下命令来查看可供安装的PHP文件版本

yum list available | grep php

安装完成后可通过php -v或php -version来验证已安装的PHP版本

其它参考链接:https://foreigngods.com/blog/2016/03/14/56/upgrade-to-php-56-on-centos-6/

喜欢 (0)
[]
分享 (0)
发表我的评论
取消评论

表情 贴图 加粗 删除线 居中 斜体 签到

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址